Cbjavaloader version confusion

I have changed the java version on my dev system from the integrated commandbox version

IMPLEMENTOR="Eclipse Adoptium"


IMPLEMENTOR="Eclipse Adoptium"

When starting Preside the following error occurs:

The stack trace is pointing me to an error in /preside/system/modules/cbjavaloader/models/javaloader/JavaLoader.cfc

Looking in preside/system/modules/cbjavaloader it says cbjavaloader-1.5.0+35-201803161656, which is quite outdated.

When trying to update preside via the commandline in commandbox it says:
cbjavaloader@^2.0.0 │ 2.1.1+8 │ 2.1.1+8 │ 2.1.1+8


Looking through the codebase I found out, that this version is located in the preside extension “Data API” (application\extensions\preside-ext-data-api\modules\cbmarkdown\modules\cbjavaloader\cbjavaloader-2.1.1+8)

I’m confused. A more recent version is implemented in the extension. but the version used in Preside is the 1.5 version.
Not sure what to do or what is happening. It looks like 1.5 isn’t working, but I have no what the right way is to update cbjavaloader.

Why did I change the Java version? I need to use a thrid party lib that is compiled for JRE 17, but I can’t get Preside up and running with this.

What now?

Thanks, Michi

While it might be worth our while looking at upgrading the version of cbjavaloader used by Preside, I think you may have other potentially more serious issues with running that version of Java. From the Lucee installation guide:

Java Versions Supported

  • The Official Lucee Installer comes with Java 11, which is our recommended version
  • Java 8 is still officially supported for 5.3, with Lucee 6 it will be no longer officially supported, but will be unofficially, as long as feasible
  • Lucee Supports Java 9 since version
  • Java 16 is not currently supported due to breaking internal changes with the jvm, LDEV-3526

We currently run our sites on Java 11.

1 Like

Thanks for the explanation. I’m fine with Java 11 and try to get the 3rd party lib as Java 11 version.